Spring IO Platform Cairo-SR7 引用的库和版本

临时所记,无图无排版

从同事那同步代码,运行程序时发现,代码是用 Spring IO Platform 管理和维护各个库和版本,使用的版本是 SR7 。我这边运行代码时发现,mysql 驱动总是报错,我本机装的 mysql 版本是 8.0+,这个报错肯定是驱动代码错误的原因,然后一看配置文件,果然。

driver-class-name: com.mysql.jdbc.Driver

这里,我将这驱动配置改成

driver-class-name: com.mysql.cj.jdbc.Driver

但这个修改后的配置文件,编译报错,woc ,这是识别不了吗?

所以就有点怀疑,这个 SR7 维护 mysql 的版本是多少。终于在他们官网找到地址

https://docs.spring.io/platform/docs/Cairo-SR7/reference/htmlsingle/

然后全局搜索「mysql」,找到如下一行

mysql

mysql-connector-java

5.1.47

果然,竟然是 5.0+ 的版本。。好吧,还好可以手动在 .pom 文件手动修改 mysql 驱动的版本,并且这个 Spring IO Platform 维护的不会覆盖。

        <dependency>
            <groupId>mysql</groupId>
            <artifactId>mysql-connector-java</artifactId>
            <version>8.0.15</version>
        </dependency>


怎么说呢?不管有用没,还是想加上这句
老郭种树原创,转载请加上Spring IO Platform Cairo-SR7 引用的库和版本
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注